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HVRC CREATE: Model Bank User Guide. 

This document contains information proprietary to IFE Digital Systems. Information contained herein 
may not be copied, reproduced, disclosed or used without the express written permission of IFE Digital 
Systems. This document may be copied for use internally at the licensed site only. 

IFE Digital Systems makes no warranties with respect to the contents or use of this document, 
including but not limited to the implied warranties of merchantability and fitness for a particular 
purpose. 

The information contained in this document is subject to change without notice. 

Java™ is a trademark of Oracle Corp. 
OpenGL® is a registered trademark of Hewlett Packard Enterprise. 
Apple®, MacOS X® and macOS® are registered trademarks of Apple, Inc. 
Microsoft® and Windows® are registered trademarks of Microsoft Corp. 

All other trademarks used within this document are the properties of their respective trademark holders.  

Comments about this document are welcome and may be sent to <create-support@ife.no>. 
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1 Overview 

1.1 HVRC CREATE 
HVRC CREATE 4 is the fourth generation of the CREATE tool suite, and builds on the technical 
platform and functionality established during the implementation of earlier versions of the software, as 
well as valuable feedback gained from usability evaluations and research work by the development 
team. 

The CREATE control room design tools combine advanced interactive 3D technology with server-
based user, project, and file management, providing an integrated package that supports and traces the 
various stages of a human-centred design process. 

The software has been designed to support a flexible, iterative, design methodology, where a control 
room design is refined and tested many times before a final design is reached. This contrasts with 
traditional control room design methods where the design process only goes through one or two human 
factors review iterations, and where it is necessary to build a costly physical control room mock-up. 
Design iterations are tracked by the system.  

When these virtual reality tools are used, it is not necessary to wait until a physical mock-up has been 
constructed before commencing design verification and validation against human factors guidelines, so 
greater emphasis can be placed on finding an optimal design solution for safe and efficient control 
room operation. Users with a variety of technical skills can operate the software, so control room 
operators, designers, human factors specialists, engineers and managers can all participate to some 
degree in the design process. 

CREATE provides features designed to support and enhance communication between the various 
interest groups involved in a design project. Support for communication between the layout designers 
and reviewers is integrated into the system, while it is possible to extract electronic documents such as 
models, designs and reports for distribution to other interested parties. 

The CREATE tools support the management of a reusable database of 3D objects, the interactive 
construction of control room layouts, and the validation of control room layouts against guidelines. 

The CREATE tools are based on cross-platform Internet and Java technology and open standards such 
as VRML97 (ISO/IEC 14772-1:1997), DAE/COLLADA (ISO/PAS 17506:2012), XML, and HTML. 

1.2 Model Bank Tool 
The Model Bank Tool is used to manage the Model Bank. 3D Models in the Model Bank are be used to 
construct (rooms and objects) and verify (manikins) control room layouts. 

Models in ISO VRML97 format are stored in a hierarchical database on the server. The models are 
grouped in categories, which can contain models and sub-categories. A model can be of one of the 
following types: manikin, room or object. 

The category structure is managed using the Model Bank Tool. 

It is also possible to save original 3D model files in the Model Bank together with the VRML model. 
The original files can be exported and the Model Bank’s version control facility can be used to replace 
an existing model with an improved version of it. 

The Model Bank Tool client can also be used as viewer for VRML models. 

In addition to ISO VRML, the Model Bank Tool can also import 3D models in the KMZ and 
COLLADA formats directly to the Model Bank, without requiring prior conversion to VRML. 
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2 Getting Started 

2.1 System Requirements 
The minimum recommended requirements for the HVRC CREATE Tools is: 

x 2 GHz Dual Core Personal Computer 
x 8GB RAM 
x 64-bit Microsoft Windows 10 or Apple Mac OS X 10.14 
x Discrete 3D graphics accelerator with at least 2GB memory and OpenGL 3.3 driver support 

(we recommend installing the demo version of HVRC CREATE if you are unsure) 
x For Microsoft Windows: 250MB free disk space for the complete tool suite. 

For macOS: 1GB. 
x A three-button mouse (or a two-button mouse with scroll-wheel "button") 

The software can be used on less powerful hardware configurations and with two-button mice, but this 
is not recommended for serious work. Use the option or alt-key on your keyboard in combination with 
the left mouse button to simulate the middle mouse button if you do not have three mouse buttons. 

2.2 Installation 
Important: See System Requirements above before installing. 

On Windows, the installer called “CREATE Tools Installer” installs the full set of tools, including the 
Model Bank Management Tool. Double-click on the installer and follow the instructions. 

On macOS, simply drag the Model Bank Tool (or the whole folder enclosing it) from the installation 
image into your Applications folder. 

2.3 Starting the Model Bank Tool 
To run the Model Bank Tool, open the CREATE directory, which was created when you installed the 
tools, and double-click on the Model Bank Tool icon. 

Depending on what options you selected when running the installer, you may also be able to start the 
tool by double clicking on an icon on the Microsoft Windows desktop or by selecting it from the Start 
menu (in the "HVRC CREATE 4.0" group). 

Important: The first time you run a CREATE tool, a wizard will appear that guides you through 
configuring your connection to a CREATE Server. After the wizard has completed, you can change 
your settings via the Preferences Window (see The Preferences Window - section 6.1). Ask your 
system administrator or project manager for assistance if you do not know what to enter. 

The information above assumes that you are using Microsoft Windows. On other platforms, the 
installation follows the platform conventions to provide easy access to the installed software. 

2.4 Support 
Please send questions, bug reports, or requests for new features to: create-support@ife.no 

When submitting bug reports, please include the following information: 

x A description of the result and how it differed from what you expected 
x The conditions or circumstances under which the problem occurred 
x Any other information that could be useful to isolate the problem, including the version of 

CREATE you are using, the version of the operating system of your computer, and the type of 
graphics card you are using. An overview of useful technical information is displayed in the 
tool’s About dialog, located in the Help menu, and can be copied into an email or saved to 
disk in a text file. 

mailto:create-support@ife.no


Release 4.1 (rev: 01/10/2022) 7 Model Bank Tool User Guide 

2.5 User Identification 
Before you can use the Model Bank Tool to do any work, the server administrator or your project 
manager must have assigned a login name and password to you. If you do not have a login name and 
password then contact the server administrator or your project manager for assistance. 

When the Model Bank Tool starts up and needs to retrieve data from the server, it will usually request 
that you enter your login name and password. If this does not occur then you should check that the 
CREATE server address has been correctly set (see The Preferences Window – Section 6.1). If the 
server address is correct then you should verify with your system administrator or project manager that 
the host is currently operating and accessible on your network. You will not be able to use the Model 
Bank Tool to do anything other than access items in the Help menu and specify the server address in 
the Preferences Window if you are not logged on to a CREATE server. 

Important: If you enter an incorrect username and/or password then you may have to restart the Model 
Bank Tool in order to log onto the server. After a successful login, you can enable an auto-login feature 
via the Preferences Window so that you do not need to enter your username and password each time. 

2.6 Changing Your Password 
You can change your password via the Edit > Set Password… menu item. For security reasons, you 
should change your password regularly and use a password that is difficult for other people to guess. 

You must be logged on to a CREATE server in order to change your password. 

To change your password: 

1. Select Edit > Set Password… 

2. The Change Password dialog will appear: 

 
The Change Password Dialog 

3. Enter a new password into the Password field 

4. Enter the new password again in the Confirm Password field 

5. Click on OK to commit the change or Cancel to abort 
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2.7 Overview of the User Interface 

 
The Model Bank Tool User Interface 

The primary Model Bank Tool user interface consists of a large window with a window title bar, main 
menu bar, and a number of panes with the main features of the tool easily accessible. 

The window title bar indicates which user you are logged in as and which server you are using, as well 
as the name of current model you are viewing. 

The menus in the main menu bar are described in Menus (see Section 4). 

The use of the panes is described in Managing the Model Bank (section 4). 

On the left side is the Model Bank Panel (see Browsing categories - Section 4.1), where the categories 
on the server can be browsed at the top and the bottom panel displays icons of the models in the 
selected category. 

In the middle is the 3D View with a toolbar (see Viewing Models - Section 4.2). The 3D View is an 
interactive 3D window where models are displayed. 

To the right is the Details Panel (see Editing model details - Section 4.7).  
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3 Creating 3D models for the Model Bank 

3.1 File format 
The internal file format used for models in the Model Bank is ISO VRML97 (Virtual Reality 
Modelling Language). VRML files can be exported from most high-end 3D modelling packages, 
including the free 3D modelling tool Blender. 

Details about ISO VRML97 can be found on the Web 3D Consortium website: http://www.web3d.org/ 

You can also directly import models stored in the COLLADA (DAE – Digital Asset Exchange) and 
KMZ formats using the Model Bank Tool. Many 3D modelling packages can export data in these 
formats, including Trimble SketchUp. Most online 3D model archives and an increasing number of 
furniture and equipment manufacturers provide models in at least one of these three supported formats. 

Regardless of whether VRML, KMZ, or COLLADA is used to transfer a 3D model into the Model 
Bank, the same basic rules apply in order to produce models that are optimised for use in HVRC 
CREATE. These are described in the following sections. Note that when importing models into the 
Model Bank Tool, functionality is provided to correct common issues on-the-fly, however if you are 
producing models yourself then it is useful to be aware of the 3D modelling practices that can make 
your model more efficient and trigger special features in the CREATE tools. 

3.2 The origin and centre of rotation 
When a model is dropped on a surface in the Layout Tool, the origin is the point where the model will 
initially be attached to the surface. When that model is rotated then it is rotated around the Y-axis 
around the origin. Using an appropriate origin is therefore important. For example, a model of a chair 
would normally have its origin at floor level with the Y-axis passing through the centre of the model. 

Below are two pictures of the same model. In the first picture, the model's centre of rotation is correct, 
while in the second picture, the centre of rotation represents an example of a location that would be 
difficult to work with interactively as the object will be positioned and rotated relative to that position 
when the user moves the object in the Layout Tool. 

  
Centre of rotation OK 

  
Centre of rotation not OK 

For objects that will be attached to walls and ceilings then the model’s Y-axis should be defined as if 
the object were to be placed flat on the floor. This ensures that the correct orientation is obtained when 
the object is placed on a wall or the ceiling. For example, a wall clock should be modelled with the 
clock face facing up and a ceiling lamp should be modelled upside down. To see examples, have a look 
at existing objects in the Model Bank that are intended to be placed on walls or the ceiling. 

The “Import Model” functionality in the Model Bank Tool enables you to correct the orientation and 
origin if necessary to the default centre of base. In special cases you may want the origin to be 
somewhere other than the middle of the base of the model, but this is rare for typical CREATE use-
cases.  

http://www.web3d.org/
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3.3 Orientation 
Models should be produced so that they are flat in the XZ-plane and with orientation around the Y-axis 
set to neutral (0). When a Layout Tool user rotates an object, it is rotated around the y-axis of the 
model relative to the centre of rotation (origin) of the object, relative to the surface on which the object 
is placed. 

Below are two pictures of the same model of a chair. In the first picture, the model's orientation is 
correct (with the legs on the group plane, which is the XZ-plane), while the orientation of the chair in 
the second image is, of course, inappropriate. When you load a model into the Model Bank Tool then it 
should normally face the user, if it is an object that is placed on the floor, e.g. a table or a shelving unit 
that stands on the floor. While there is no harm in such units being oriented differently around the Y-
axis, since the Y-rotation can be modified in the Layout Tool, it is easier for the end-user if the 
direction that objects face in is consistent. 

  
Orientation OK 

 
Orientation not OK 

3.4 Lights 
3D models representing lights can be used for "light" models and are permitted to contain 3D lights that 
cast light. All other models that would not naturally cast light should not contain lights. Room models 
may contain lights. But that is not required as the Layout Tool provides a general 'indoor lighting' 
option which is normally preferable. 3D models added to the Model Bank can have realistic lighting 
effects baked into their textures, however these will, of course, not affect other models added to a 
layout. A baked room can be very effective for showcasing a final design but is not recommended for 
conceptual design work where you are likely to want to export a “clean” 3D model from the Layout 
Tool to other tools for further detailing or high-quality rendering, including baking of shadows for a 
showcase version of a final layout. 

3.5 Inline files 
A 3D model file (VRML97, DAE, KMZ) imported into the Model Bank may contain internal 
references to other 3d data files, image files for textures, and other resources. If the referenced files are 
not in the same directory (or a sub-directory) as the main model file, the Model Bank Tool will attempt 
to copy them and reorganise the file structure of copy of the model that will be added to the database, 
so the resulting model in the Model Bank is guaranteed to be complete. 

3.6 Textures 
Textures should follow usual conventions for 3D models intended for interactive applications. Textures 
should not be larger than necessary to conserve texture memory -- it is not typically necessary for 
textures to be larger than 512x512 in size, and it is generally good practice to provide images using 
powers of 2 (i.e. 4x4, 8x8, 16x16, 32x32, etc.) pixel dimensions for optimal performance. Most 
graphics cards do not support textures larger than 4096 x 4096 at all. 
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We recommend using PNG-format for textures to avoid compression artefacts, although for 
photographic-type images, JPEG may give adequate results with smaller file sizes. PNG is preferable to 
GIF when using transparency as it supports finer control of transparency levels. 

The colour of surfaces and the textures are blended, so you should normally use white materials “under 
your textures” if you want the texture’s own colour to dominate. 

3.7 Supported VRML and COLLADA features 
Only static ISO VRML 97 geometry is supported. Animations, scripted, or interactive features are 
generally ignored. This is also the case for such features in formats such as COLLADA. 

3.8 Creating manikins in VRML 
Manikins should be modelled following the ISO/IEC FCD 19774 H-ANIM 1.x standard. See: 
http://www.h-anim.org/ for details. 

For a model to be used as a manikin in HVRC CREATE to evaluate line of sight and reach, the follow 
nodes are required: 
HumanoidRoot 
  skullbase 
    l_eyeball_joint 
    r_eyeball_joint 

and 

l_shoulder 
    l_elbow 
      l_wrist 
        l_middle_distal_tip 
r_shoulder 

These node names may optionally have a hanim_ prefix. Note that these nodes have to be in the file in 
the correct order, with no nodes between those specified, otherwise the manikin may not work correctly 
in the Layout Tool and Verification Tool. It is also important that the joints above are positioned 
without rotation for correct reach to be calculated. For both arms to be handled with differing lengths 
r_elbow, r_wrist and r_middle_distal_tip can also be specified, otherwise it is assumed 
that the right arm is the same length as the left arm. 

Note that IFE can supply custom-specified manikins for CREATE that fulfil these requirements. Please 
contact CREATE Support for assistance. 

3.9 Creating rooms 
Rooms can be modelled in the Layout Tool itself or in a 3D modelling package for inclusion in the 
Model Bank. This section concerns pre-modelled rooms that will be added to a Model Bank. 

Rooms can be modelled in a way that makes it possible to hide and show parts of the room to make 
viewing and editing easier in the Layout Tool or Verification Tool. In most cases, at least the ceiling 
should be identified to enable the user to hide it and more easily access the contents of the room. 

To make part of a room identifiable, that part (node) has to be named in the model data. Note that when 
part of a room is hidden or shown, any children of that part will also be toggled. The model should 
therefore be structured appropriately. 

VRML97 Example: 
#VRML V2.0 utf8 
DEF Room Group { 
  children [ 
    DEF Floor   Transform { … } 
    DEF Ceiling Transform { … } 
    DEF Walls   Transform { … } 
    …   
  ] 
} # end of Room 

Note that …in this example indicates additional code. 

http://www.h-anim.org/
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3.10 Defining ideal snap locations (snap boxes) for modular 
models 

A model can contain one or more invisible snap boxes that indicate the ideal locations where associated 
models (e.g. modular furniture or walls) can be joined together. The models can then be rapidly 
attached to each other in the Layout Tool.  

When two snap boxes collide in the Layout Tool, the box belonging to the model that is being moved 
will be aligned so that it’s centre and orientation is the same as the snap box belonging to the stationary 
model (for more details see the Layout Tool documentation). 

Requirements for snap boxes in a model: 

x Snap boxes must have a name (node identifier) starting with ‘snapBox’. If there are more than 
one snap box in the model the ids should be unique for each snap box. The snap box should be 
a modelled as a Shape (typically with Box geometry). 

x Snap boxes should not use shared geometry or appearances. 

x The transparency field of the Material node should be used to set the snap box invisible. 

VRML97 Example: 
DEF snapBox Shape { 
 
  appearance Appearance { 
    material Material { 
      transparency 1.0 
    } 
  } 
 
  geometry IndexedFaceSet { 
    Coordinate { 
      Point [ 
        … 
      ]   
    } 
  } 
 
} 

 
Note that … in this example indicates additional code. 
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4 Managing a Model Bank 
The Model Bank Tool is used to install and update 3D models that can be used to construct control 
room layouts. Models are stored in a hierarchical database on the server. The models are grouped in 
categories, which can contain models and sub-categories. The Model Bank tool can be used to manage 
categories and models on the Model Bank server and to view both models on the Model Bank server 
and VRML, DAE, and KMZ models on a local file system. 

4.1 Browsing categories 
Model Bank categories can be browsed in the Model Bank panel. There are three types of categories – 
object categories, room categories, and manikin categories. Empty categories are greyed out in the tree 
view of the Model Bank. Categories can have sub-categories. 

 
Model Bank Panel 

To browse categories: 

1. Click on a category in the tree or a category icon to select it. Icons of the models in the 
category and sub categories of the selected category will be showed in the lower part of the 
Model Bank panel. 

2. If a category contains subcategories a handle is placed next to that category in the tree view of 
the model bank. By clicking the handle you can choose to show or not show the subcategories. 
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4.2 Customising catalogue icon display 
It is possible to choose between small or large model and catalogue icons and to choose whether to 
display an item’s name on the model icon. 

To choose small icons: 

1. Select View > Small Catalogue Icons 

To choose large icons: 

1. Select View > Large Catalogue Icons 

To display an item’s name on the model icon: 

1. Select View > Catalogue Icon Text 

4.3 Viewing models 
3D models on the local file system in support formants, and models in a Model Bank can be viewed in 
the 3D View pane. The 3D view is an interactive 3D window with a toolbar above it. 

 
3D View 
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3D View toolbar 

From left to right the buttons in the 3D view toolbar are: 

(Please note that only the first six buttons are always visible in the 3D View toolbar). 

Study Model button is used to toggle between “study” state, and “auto rotate state”. 

Show Dimensions button is used to toggle the dimension visualization on or off. 

Show Grid button is used to toggle the grid on or off. 

Show Coordinate System button is used to toggle the coordinate system on or off. 

Model Information button is used to toggle a window with information about the loaded 
model (See Viewing model information). 

Model Details button is used to toggle the Model Details side-panel that can be used to 
edit data about the item the model represents, such as it’s name, 
manufacturer, price, and other comments (see Editing model 
details). 

Snap Box Visibility button is used to toggle the visibility of snap boxes in the model. This 
button is only visible if there are snap boxes defined in the loaded 
model. 

Room Configuration button is used to display a room configuration window for room models. 
Note that the room configurator is just for temporarily examining 
the model and doesn’t make any permanent changes in the model. 
This button is only visible if a room model is loaded. It enables 
you to toggle visibility of named parts of a room model. 

 
Room Configuration window 

To view an existing Model Bank model: 

1. To view a Model Bank model in the 3D View click on the model icon with the left mouse 
button, or drag it into the 3D View by pressing the left mouse button over the icon and drag it 
to the 3D View before releasing the left mouse button (see Browsing categories). 

2. A red frame around the model icon indicates that this is the loaded model. 

See also: 

Adding a new model to a Model Bank 
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4.3.1 Navigation 
The user can toggle between two states for displaying a model in the 3D View. If the Study Model 
button is not selected, the model is displayed rotating and fit to the 3D view – this is a non-interactive 
mode. 

If the Study Model button is selected the user can rotate, zoom and pan the model. 

To rotate the model: 

1. Make sure the Study Model button is selected. 

2. Use the left mouse button (by dragging) to rotate the model in the 3D View. Imagine an 
invisible bounding sphere around the model that you rotate. 

To zoom the model: 

1. Make sure the Study Model button is selected. 

2. Use the middle mouse button (by dragging) in the 3D view to zoom the model. 
Zoom in by dragging the mouse cursor with a vertical movement from top to bottom. 
Zoom out by dragging the mouse cursor with a vertical movement form bottom to top. 

To pan the model: 

1. Make sure the Study Model button is selected. 

2. Use the right mouse button (by dragging) in the 3D view to pan the model. The model will be 
moved in the direction you drag the mouse. 

4.3.2 Displaying a visual grid 
A grid indicating the position of the ground relative to the model can be toggled in the 3D View. 

To toggle the grid: 

1. Select the Show Grid button or the View > Show Grid menu item to show the grid. 

2. Deselect the Show Grid button or View > Show Grid menu item to hide the grid. 

To configure the grid: 

1. Select View Grid Options… to display the grid options dialog. 

2. Press OK or Apply to apply changes, or Cancel. Pressing OK or Cancel dismisses the options 
window. 

4.3.3 Indicating the centre of rotation of an object 
A coordinate system with x- y- and z-axes that indicates the position of the model’s centre of rotation 
can be toggled in the 3D View. 

To toggle the coordinate system: 

1. Select the Show Coordinate System button or the View > Show Coordinate System menu item 
to show the coordinate system. 

2. Deselect the Show Coordinate System button or the View > Show Coordinate System to hie 
the coordinate system indicator. 

4.3.4 Displaying object dimensions and bounding area 
An indication of the dimensions of the model can be toggled in the 3D View. 

To toggle 3d labels showing the model dimensions: 

1. Select the Show Dimensions button or the View > Show Dimensions menu item to show the 
dimensions. 

2. Deselect the Show Dimensions button or the View > Show Dimensions menu item to hide the 
dimensions. 



Release 4.1 (rev: 01/10/2022) 17 Model Bank Tool User Guide 

4.3.5 Viewing model as a wireframe 
Viewing a model as a wireframe can help you to identify potential problems with the model, such as 
misplaced polygons or poor optimisation (more polygons than necessary). 

To view a model as a wireframe: 

1. Select View > Wireframe. 

2. Deselect View > Wireframe to turn off wireframe viewing. 

4.4 Adding a new model to a Model Bank 
A VRML model on the local file system can be added to a Model Bank as-is. It can be of one of these 
types: normal Object, Room, or Manikin. Each of these types of models is handled in a slightly 
different way. 

When you select Open... from the File menu a dialog appears where you specify the type of model that 
you will open. You will then be able to select a file and open the model. The model is displayed in the 
3D view but must be saved if you want to store it in the Model Bank. To save the model to the server, 
select File > Save… 

If you open a model that is detected to conform to the requirements of a manikin as a normal object 
then you will be asked to confirm that you want to open it as an Object rather than a Manikin. 

Note that white space or non-ASCII characters in file names are not permitted. You will be able to 
open and view the model regardless of the filename format but will not be allowed to save it unless the 
filename is conformant. Please modify the filename and then open the model again if the Model Bank 
Tools gives a warning about this. If the model uses resources (such as textures files) with filenames that 
do not conform then use the Import Model method (see next paragraph) to open the model instead. 

Alternatively, models can be imported in the VRML, KMZ or COLLADA format using the Import 
Model… option in the File menu, which offers an additional dialog displaying a preview and controls 
to perform quick fixes for typical issues with models, such as correcting origin, rotation, scale, and 
orientation. See Importing a COLLADA, KMZ or ISO VRML97 3D Model for details. Support for 
additional 3D model formats can be enabled via the Preferences dialog (See Expert Preferences). 

Note that if you double-click on a file in order to open it then (if the Model Bank Tool is the default 
handler for that 3D model type) a VRML97 file will be opened as an Object as if opened using File > 
Open… while other COLLADA and KMZ files are treated as if you had selected File > Import. 

See also: 

Storing the original 3D model files with a new model 

Expert Preferences 

Exporting a model 

4.4.1 Adding a new model 
To open an ISO VRML97 model of an object without modification: 

1. To open a model on the local file system choose File > Open … and select Object type from 
the dialog that appears. 

2. If you already have a locally placed model opened, you will be asked if you want to save this 
to the Model Bank server (see below). 

3. A file chooser will be displayed where you can select the VRML model you want to open. 
Browse the file system, select the VRML file and click the Open button.  

To open a model of an object in any supported 3D format with preview and other options: 

1. To open a model on the local file system choose File > Import … and select Object type from 
the dialog that appears. 

2. If you already have a locally placed model opened, you will be asked if you want to save this 
to the Model Bank server (see below). 
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3. A file chooser will be displayed where you can select the 3D model you want to open. Browse 
the file system, select the 3D model file and click the Open button.  

To add a new model to the Model Bank server: 

Open a model from the local file system (see above). 

1. If you wish to enter details for the model do that in the Details panel. 

2. Choose File > Save… 

3. A Select Category dialog will be opened. Select the category you want to save the loaded 
model to and click the OK button. Only categories for object models are available in the Select 
Category dialog – an object model cannot be saved into a room category or a manikin 
category.  

 
Select Category dialog 

4. The model is now saved on the server in the selected category. 

See also: 

Storing the original 3D model files with a new model 

4.4.2 Adding a new room 
To open an ISO VRML97 room model without modification: 

1. To open a room model on the local file system choose File > Open … and select Room type 
from the dialog that appears. 

2. If you already have a locally placed model opened, you will be asked if you want to save this 
to the Model Bank server (see below). 

3. A file chooser (see Adding a new model) will be displayed where you can select the VRML 
room model you want to open. Browse the file system, select the VRML file and click the 
Open button.  
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To open a model of a room in any supported 3D format with preview and other options: 

1. To open a room model on the local file system choose File > Import … and select Room type 
from the dialog that appears. 

2. If you already have a locally placed model opened, you will be asked if you want to save this 
to the Model Bank server (see below). 

3. A file chooser (see Adding a new model) will be displayed where you can select the 3D room 
model you want to open. Browse the file system, select the 3D file and click the Open button.  

To add a new room model to the Model Bank server: 

1. Open a room model from the local file system (see above). 

2. If you wish to enter details for the room model do that in the Details panel. 

3. Choose File > Save…  

4. A Select Category dialog (see Adding a new model) will be opened. Select the category you 
want to save the loaded model to and click the OK button. Only room categories are available 
in the Select Category dialog - a room model can only be saved into a room category.  

5. The room model is now saved on the server in the selected category. 

See also: 

Storing the original 3D model files with a new model 

4.4.3 Adding a new manikin 
To open an ISO VRML97 manikin model without modification: 

1. To open a manikin model on the local file system choose File > Open … and select Manikin 
type from the dialog that appears 

2. If you already have a locally placed model opened, you will be asked if you want to save this 
to the Model Bank server (see below). 

3. A file chooser (see Adding a new model) will be displayed where you can select the VRML 
manikin model you want to open. Browse the file system, select the VRML file and click the 
Open button. 

4. The manikin file will be checked to see if it is a valid manikin file. If it isn’t a valid manikin 
file the user will see a warning, and the model will be treated as a normal model.  

To open a model of a manikin in any supported 3D format with preview and other options: 

1. To open a manikin model on the local file system choose File > Import … and select Manikin 
type from the dialog that appears 

2. If you already have a locally placed model opened, you will be asked if you want to save this 
to the Model Bank server (see below). 

3. A file chooser (see Adding a new model) will be displayed where you can select the 3D 
manikin model you want to open. Browse the file system, select the 3D file and click the Open 
button. 

4. The manikin file will be checked to see if it is a valid manikin file. If it isn’t a valid manikin 
file the user will see a warning, and the model will be treated as a normal model.  

To add a new manikin model to a Model Bank server: 

1. Open a manikin model from the local file system (see above). 

2. If you wish to enter details for the manikin model do that in the Details panel. 

3. Choose File > Save… 

4. A Select Category dialog (see Adding a new model) will be opened. Select the category you 
want to save the loaded model to and click the OK button. Only manikin categories are 
available in the Select Category dialog - a manikin model can only be uploaded into a manikin 
category.  
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5. The manikin model is now saved on the server in the selected category. 

See also: 

Storing the original 3D model files with a new model 

4.4.4 Importing an image for use as an object 
You can import images to be used as objects in a layout. This can be useful for rapidly creating static 
images for computer displays, posters, sheets of paper, and so forth. Note that the Layout Tool provides 
a similar opportunity using a parametric Image Surface object, however the Model Bank Tool enables 
you to create image objects that can be easily shared between projects and provides a wizard to enable 
rapid sizing to standard display and paper sizes. 

To import an image: 

1. To import a locally placed image, choose File > Import Image… 

2. If you already have a locally placed model opened, you will be asked if you want to save this 
to the Model Bank server (see below). 

3. A file chooser will be displayed where you can select the image file you want to import. 
Browse the file system, select the image file and click the Open button. 

4. An Image Import Wizard, where the user can choose model dimensions and image 
optimisations, will be opened. Choose the desired values and click the OK button to generate 
an image model, or Cancel to abort. 

 

 
Image Import Wizard 

To add a new image model to the Model Bank server: 

1. Make sure that you have an image on the local file system opened (see above). 

2. If you wish to enter details for the image do that in the Details panel. 

3. Choose File > Save… 

4. A Select Category dialog (see Adding a new model) will be opened. Select the category you 
want to save the loaded model to and click the OK button. Only object categories are available 
in the Select Category dialog – an image can only be uploaded into an object category.  

5. The image is now saved on the server in the selected category.  
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4.4.5 Importing an ISO COLLADA, KMZ or ISO VRML97 3D Model 
Importing a model enables you to preview it and perform and correct issues with it before adding it to 
the Model Bank database. Note that VRML models can be either opened or imported but the result is 
not the same, even if no manipulations are selected. When Import is used, the model geometry is 
optimised and textures regenerated so the VRML data will be modified by import. When using Open to 
add a VRML model then only paths to resources are modified in the VRML file added. 

The last selected model manipulation options are presented as default in the preview dialog, making it 
quicker to import multiple models with the same issue (e.g. a set of models all need to be rotated 
around Y 180 degrees and need scale corrected from cm to m). 

In addition to ISO COLLADA (DAE), ISO VRML97 (WRL), and KMZ (compressed Keyhole Mark-
up Language with embedded COLLADA model, as used by Google Earth) formats, support for 
additional 3D formats can be enabled via the Preference dialogue. These include LWO, OBJ, PLY, and 
SCENE (Ogre3D) formats. See Expert Preferences for details.  

To import a new model with option for additional processing during import: 

1. To import a model on the local file system choose File > Import Model…  

2. If you already have a locally placed model opened, you will be asked if you want to save this 
to the Model Bank server (see below). 

3. A dialog will appear requesting you to specify the type of model you will open (object, 
manikin, or room). Select a type and the press OK, or Cancel to abort the operation. 

4. A file chooser will be displayed where you can select the model you want to open. Browse the 
file system, select the file and click the Open button, or Cancel to abort the operation 

5. A dialog will appear displaying a preview of the model and controls you can used to perform 
some common manipulations to it. The resulting model will be displayed in the main 3D View 
when you close the preview dialog. 

 
Model Import dialog window.  

To add a new model to the Model Bank server: 

Make sure you have a model on the local file system opened (see above). 

1. If you wish to enter details for the model do that in the Details panel. 

2. Choose File > Save… 
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3. A Select Category dialog will be opened. Select the category you want to save the loaded 
model to and click the OK button. Only categories for object models are available in the Select 
Category dialog – an object model cannot be saved into a room category or a manikin 
category. 

See also: 

Expert Preferences 

Storing the original 3D model files with a new model 

Exporting a model 

4.4.6 Storing the original 3D model files with a new model 
The original files (e.g. 3D Studio Max or Blender files) used to create a 3D model can be archived 
together with the model added to the Model Bank by placing copies of those files in a zip-archive.  

The zip archive with original files can be exported from the Model Bank for future editing by selecting 
File > Export Model… when the model you want to export has been loaded into the 3D view. 

To archive the original files together with a new model: 

1. Place a zip-archive in the same folder as the model file you will open to add to the Model 
Bank. The zip file should have the exact same name as the model file, except for the file 
extension, which should be .zip. For example, if the VRML file is named ‘model.wrl’ then the 
original file (or zip archive) should be ‘model.zip’. 

2. The original file will then be detected and stored with the model if the model is opened or 
imported and subsequently saved to the server (see Adding a new model). 

See also: 

Exporting a model 

4.5 Installing a package containing a set of models 
A model package is a set of models that have been archived together for easy distribution and 
installation. For example, upgrades to the standard models and optional categories may be supplied as 
Model Bank Packages that can be installed using a single operation by a Model Bank Tool user. 

To install a model package: 

1. Select File > Install Package… 

2. Select the package file (a zip archive) that you wish to install in the file 
dialog that appears (or Cancel if you change your mind). 

3. The package data will be installed on the server and the model bank 
catalogue view will be refreshed. 

4.6 Exporting a model 
A model can be exported from the Model Bank Server. If the original 3D model files were included in 
the zip file when a model was uploaded to the Model Bank server (See Section 4.4), the original files 
will be exported together with the model. 

To export a model: 

1. Open a model on the Model Bank server (see Viewing Models). 

2. To export the uploaded files for the loaded model choose File > Export Model… 

3. A file chooser will be displayed where you can select the folder you want to save the model 
files in. Browse the file system, select a folder and click the Open button. 

4. The model files are now saved in the selected folder.  

See also: 

Adding original 3D model files 
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4.7 Editing model details 
Model details for a model in the Model Bank can be edited. These are the details that are shown to end-
users of the Layout Tool and can appear in inventory reports produced using the Layout Tool.  

To edit model details: 

1. Open a model (see Viewing Models). 

2. Enter or modify details about the model in the fields of the Details side-panel. 

3. When you have finished making changes, choose File > Save to commit them to the database. 

See also: 

Tagging models with meta-data 

4.8 Viewing model information 
Information about a model and its associated resource files (typically texture data) can be viewed. 

To view model information: 

1. To view model information for the loaded model choose Window > Model Info…, use the 
Model Information button in the 3D view toolbar (See Viewing Models), or right click on the 
model icon and selecting ‘Model Info’ in the popup menu. 

 
Model Info menu item in popup menu 

2. If the model info window is opened it will be updated with information about the currently 
loaded model. 

 
Model Info window  

4.9 Moving a model to a different category 
A model can be moved to a different category. When a model is moved to a different category, a copy 
of the model is placed in the new location and the original is deleted (see Deleting a model). If a model 
is to be moved to a category where there is already a model (including hidden models) with the same 
name then the moved object must be given a new name, otherwise the move operation is not permitted.  
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To move a model: 

1. To select a model to be moved, choose Edit > Cut Item, or right-click on the model icon (see 
Browsing categories) and choose Cut in the popup menu. Note that the Cut Item menu item in 
the main menu works on the loaded model, the Cut menu item in the popup menu works on 
the model the icon represents. 

2. Select the category you want to move the model to and choose Edit > Paste, or right-click on 
the category and choose Paste in the popup menu. 

3. The model is now moved to the new category. 

4.10 Deleting a model 
A model can be deleted. When a model is deleted it remains archived on the server but is flagged as 
hidden. It is logically no longer available but physically remains on the server. A hidden model can no 
longer be selected (it is not shown) in the Project Management Tool for use in new projects. However, 
the hidden model remains available to existing projects that use it. 

To delete a model: 

1. To delete a model choose Edit > Delete Item or right-click on the model icon  (see Browsing 
categories) and choose Delete in the popup menu. Note that the Delete Item menu item in the 
main menu works on the loaded model, the Delete menu item in the popup menu works on the 
model the icon represents. 

2. You will then see a confirmation dialog where you are asked if you really want to delete the 
model. If your answer is yes the model will be deleted. 

4.11 Creating a new category 
New categories can be created anywhere in the hierarchy (except in hidden categories). A category can 
be of one of these types; object category, room category or manikin category. 

To create a new category: 

1. Select the category you want the new category to be a sub category of. If you want to create a 
category at the top level you select the Model Bank root node. 

2. Choose Edit > Add Category… or right-click on the selected category (see above) and choose 
Add Category… in the popup menu. 

3. An Add Category dialog will be displayed where you enter the name of the new category and 
select type (object, room or manikin). When you are finished click OK, or Cancel to abort. 

 
Add Category dialog 

3. A new category is then created on the Model Bank server. 

4.12 Renaming a category 
A category can be renamed. The same mechanism as for moving a model is used (see Moving a model 
to a different category) but in this case all models and sub-categories in the original category also are 
copied before the original is deleted (see Deleting a model). 
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Any already hidden categories and models in a category that is being renamed are not copied from the 
original to the new location. 

 

To rename a category: 

1. Select the category you want to rename. 

2. Choose Edit > Rename Category… or right-click on the selected category (see above) and 
choose Rename in the popup menu. 

3. A Rename Category dialog will be displayed. Enter the new name of the category and click 
the OK button, or Cancel to abort. 

 
Rename Category dialog 

4. The category is now renamed. 

4.13 Moving a category 
A category can be moved. The same mechanism as for moving a model is used (see Moving a model to 
a different category) but in this case all models and sub-categories in the original category also are 
copied before the original is deleted (see Deleting a model). 

Any already hidden categories and models in a category that is being moved are not copied from the 
original to the new location. 

To move a category: 

1. Select the category you want to move. 

2. Choose Edit > Cut Category or right-click on the selected category (see above) and choose 
Cut in the popup menu. 

3. Select the category (or the Model Bank root node) you want to move the category to and 
choose Edit > Paste or right-click on the category and choose Paste in the popup menu. 

4. The category is now moved to the new location. 

4.14 Deleting a category 
A category can be deleted. When a category is deleted it remains archived on the server but is flagged 
as hidden. It is logically no longer available but physically remains on the server. All models (see 
Deleting a model) and sub-categories in the deleted category are also deleted (flagged as hidden). A 
hidden category and its children can no longer be selected (it is not shown) in the Project Management 
Tool for use in new projects. However, the hidden category remains available to existing projects that 
use it or its children. 

To delete a category: 

1. Select the category you want to delete. 

2. Choose Edit > Delete Category or right-click on the selected category (see above) and choose 
Delete in the popup menu. 

3. A confirmation dialog will be displayed and you will be asked if you are sure that you want to 
delete the category – click the OK button to delete the category. 



Release 4.1 (rev: 01/10/2022) 26 Model Bank Tool User Guide 

4. The category is now deleted. 

4.15 Set background colour in the 3D view 
The background colour in the 3D view can be changed. The chosen background colour will be 
remembered the next time the Model Bank Tool is used. 

If no background is selected then a white background is drawn, which is often appropriate to use when 
printing. 

To change the background colour in the 3D view: 

1. Select View > Set Background Colour… 

2. Choose the preferred colour in the ‘Set Background Colour’ dialog and click 
the OK button. 

3. Select View > Show Background 

4.16 Printing a model 
A full-page image of the 3D view can be printed. 

As the aspect of your paper will often differ from that of the image on the screen, you may need to 
zoom out the image in the 3D view a little to ensure that it fits on your page without getting clipped. 

You must always set the orientation of the paper using the page setup dialog.  

Note that the dialog windows shown by the Model Bank Tool will depends on the operating systems 
you are using, so the actual dialog window on a computer running Linux will differ from the equivalent 
dialog window on a computer running Windows or OS X. 

You can turn off the background for a white background when printing (see Set background colour in 
the 3D view). 

To set up the page: 

1. Select File > Page Setup… 

2. Choose the required settings and confirm or reject your changes 

To print the current guideline and procedure or index: 

1. Select File > Print… 

2. Choose the required settings 

3. To ensure correct results, do not select orientation using the print dialog 
(Use File > Page Setup… instead) 

4. Press OK to print or Cancel to abort 

4.17 Exporting a 2D image of a model 
A 2D graphic of the 3D view can be exported in either PNG or JPEG format. PNG is recommended for 
best image quality while JPEG gives smaller file size. 

The dimensions in pixels of the exported image are configurable, enabling you to control the aspect and 
resolution of the image produced. 

Image Size options: 

x Screen – Produces an image with model fit to the resolution of you main display 
(e.g. 1920 x 1080 if you are using a HD-resolution display) 

x Current – Produces an image that is the same size as the 3D view currently displayed 

x Other – Produces an image with model fitted at the resolution specified. A warning will be 
given for especially high-resolution images as this option can potentially result in an out-of-
memory situation. Therefore, always save your work before using this if you intend to attempt 
resolutions greater than about 4096 x 4096. 
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Save Image dialog  

To save a 2d graphic image of the 3D view: 

1. Select File > Export 2D Graphic… 

2. Select options in the dialog that appears.  

3. Choose save to display a file save dialog or cancel to abort. 

4.18 Tagging models with meta-data 
In the Layout Tool, the designer can tag models with meta-data that describes the purpose or role of an 
object in a layout. This can be used to automate aspects of testing against requirements and guidelines. 
The Model Bank Tool also support tagging of models with general tags that, if set, save time for the 
designer using the models. For example, computer screens can be tagged with “display”, work desks as 
“desk” and so on. The set of tags that can be set in the Model Bank Tool is limited in comparison with 
those that can be set in the Layout Tool as the tags set in the Model Bank Tool are intended to be 
irrespective of the guideline set used in the Layout Tool or Verification Tool. 

Tags are set on individual options by clicking on the Tags field under Model Details, 
and then ticking the tags that apply. 

For convenience, if updating a large number of models, a tool (Model Tag Editor) for 
batch-modifying tags (both setting and removing) is provided in the Window menu. 

To add/remove tags for an individual model in the Model Bank: 

1. Load the model in the 3D view and make sure that the Details panel is 
displayed to the right 

2. Click on the Tags field to reveal a dialog with scrolling list of tags

 
3. Select/deselect tags as appropriate for the model. Note that the selected tags 

are listed in the tags field. 
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4. Select File > Save to store the changes 

To batch add/remove tags to multiple models in the Model Bank: 

1. Select Window > Model Tag Editor 

2. The Model Tag Editor window will appear (see image below). 

3. Add the tags that you want to work with from the Available Tags to 
Selected Tags panel using the add and remove (< and > ) buttons. 

4. Select the models that you want to modify using the Model Bank view and 
model icons in the Model Tag Editor window. Note that you need to click 
on each model to select it but you can also right-click on the category and 
choose “Select all in folder”. The objects that are selected as listed in the 
Selected Models list. 

5. You can remove individual models from the Selected Model list by selecting 
them and pressing the – button. You can also press Clear All to empty the 
list 

6. Choose the action that you want to perform. Either you assign the selected 
tags to all of the selected models or you remove the selected tags from all 
the models. Note that removing a tag that is not actually assigned to a model 
will have not effect. 

7. To apply the changes, press the Apply button. Note that changes are saved if 
you confirm the changes after pressing Apply. To cancel, just close the 
dialog without applying changes 

 
The Model Tag Editor window 

 

 



Release 4.1 (rev: 01/10/2022) 29 Model Bank Tool User Guide 

5 Menus 

5.1 File Menu 

 

The File menu holds menu items for managing files locally and on the server, menu items related to 
printing and a menu item for exiting the program. 

Some of the available items in the File menu have keyboard shortcuts (shown to the right of the menu 
items above). 

Open… is used to open a model (not room or manikin). (See Add a new 
model) 

Save is used to save a model to the Model Bank (See Add a new model 
to the Model Bank) and to save changes to model details for a 
model already in the database. 

Import Image… is used to import and image as a flat 2D object (See Add a new 
image). 

Import Model… is used to import a 3D model in VRML, KMZ or COLLADA 
format (See Importing a COLLADA, KMZ or ISO VRML97 3D 
Model ). 

Export Model… is used to export a model from the Model Bank database (See 
Exporting a model). 

Export 2D Graphic… is used to export a 2D image of the 3D view to file (see Exporting 
a 2D image of a model). 

Install Package… is used to install a pre-made package containing a set of models 

Page Setup… is used to set printing properties (See Printing a model view). 

Print… is used to print the 3D view (See Printing a model view). 

Exit is used to quit the Model Bank Tool. If you choose this menu item 
then you will be requested to confirm that you want to quit. All 
unsaved work will be lost if you exit without first committing 
changes. 
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5.2 Edit Menu 

 
The Edit menu holds menu items for managing the categories and items on the Model Bank server and 
it holds menu items for changing password and switching to a new Model Bank server. 

Some of the available items in the Edit menu have keyboard shortcuts (shown to the right of the menu 
items above). 

Add Category… is used to add a new sub category to the selected category in the 
Model Bank (See Creating a new category). 

Cut Current Model is used to cut (select to be moved) the loaded model (See Moving 
a model to a different category). 

Cut Category is used to cut (select to be moved) the selected category in the 
Model Bank (See Moving a category). 

Paste is used to paste the selected item – category or model – into the 
selected category in the Model Bank (See Moving a model to a 
different category and Moving a category). 

Rename Category… is used to rename the selected category in the Model Bank (See 
Renaming a category). 

Delete Category is used to delete the selected category in the Model Bank (See 
Deleting a category). 

Delete Current Model is used to delete the loaded model in the Model Bank (See 
Deleting a model). 

Set Password… is used to change your password (See Changing Your Password). 

Preferences is used to open the Preferences Window (See The Preferences 
Window for usage information). 
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5.3 View Menu 

 
Refresh Catalogue Refresh the category overview from the Model Bank database. 

Small Catalogue Icons select this to see small icons of the models. 

Large Catalogue Icons select this to see large icons of the models. 

Catalogue Icon Labels select this to display an item’s name on the model icon. 

Wireframe select this to display the model as a wireframe (see Viewing 
model as a wireframe) 

Show Coordinate System select this to display an indicator at the origin of the coordinate 
system with an indication of the X, Y and Z directions (see 
Indicating the centre of rotation of an object). 

Show Dimensions select this to display the model enclosed in a wireframe box 
indicating the dimensions of the model  (see Displaying object 
dimensions and bounding area). 

Show Background select this to display a coloured background. 

Set Background Colour… is used to change the background colour in the 3D view (See Set 
background colour in the 3D view). 

Show Grid select this to display a grid under the model. 

Grid Options… is used to configure the grid (colour and spacing). 

5.4 Window Menu 

 
Model Info… is used to display a window with information about the loaded 

model (See Viewing model information). 

Model Tag Editor… is used to batch modify tags associated with models instead of 
setting tags for each model using the Details panel (See Tagging 
models with meta-data). 
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5.5 Help Menu 

 

The Help menu provides access to copyright information about this software and to online help. 

About HVRC CREATE… Display copyright information about the CREATE tool suite. 

About Model Bank Tool… Display technical information about this tool. 

Check for Update is used to check if the latest version of this tool is being used. 

Model Bank Tool Help Access the online user guide for the Model Bank Tool. 
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6 Configuration  

6.1 The Preferences Window 
 

 
The Preferences Window 

The first time you use one of the CREATE tools you will normally be presented with a wizard that 
assists you in setting the configuration options that you need to get started using HVRC CREATE. 
Subsequently, you can adjust your personal configuration via the options in the Preferences Window. 

The Preferences Window can be accessed from the main menu bar's Edit > Preferences… menu item. 
The keyboard shortcut to open the Preferences Window is ctrl-comma (or command-comma). 

Changes to preferences are global and therefore affect all CREATE tools that you use, however they 
are also personal and will not affect any other users of CREATE that share a computer as long as you 
are not sharing a computer user account. 

There are four sets of preferences in the Preferences Window, the most important of which is the 
“General” set, which is used to enter the address of the CREATE server that will be used. The 
individual sets and the options they contain are described in the subsections below. 

The Preferences Window has three buttons: 

x OK is used to update the preferences and close the window 

x Apply is used to set the update the preferences but not close the window 

x Cancel is used to dismiss the window without making any changes 

Clicking Apply followed by Cancel is equivalent to clicking OK. 

A configuration file containing your preferences is created in your home directory and will be applied 
the next time you run a CREATE tool. 

Closing the window by clicking on the close box (top right of the window) is equivalent to clicking on 
the Cancel button. Hitting the escape key is also equivalent to clicking on the Cancel button. 
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6.1.1 General Preferences 

 
The General Preferences section of the Preferences Window with server create.ife.no set 

The General Preferences section of the Preference Window is used to set the CREATE server URL, to 
specify the appearance of the CREATE tools, and to toggle caching to local disk of 3D models in the 
Model Bank. 

Important information about changing the server URL: 

x In general, it is recommended that you change the server URL setting either immediately after 
starting up a tool or immediately after saving any unfinished work to the current server, to 
avoid any risk of data loss before switching to a different server. 

x If you are behind a firewall and are using a proxy server to access the internet then you should 
also refer to Proxy Preferences – section 6.1.3 if you need to access a CREATE server that is 
not on your local network (e.g. to access the demonstration server on create.ife.no). 

If some features of the tool are not working correctly and the software is reporting server access 
errors then the reason may be that the server is incorrectly configured, in which case you should 
report this to your CREATE server administrator. 

The General options are described below: 

CREATE Server URL The server URL is the Web address of the CREATE server where 
all CREATE system and project data is stored. It is shared by all 
of the tools. If you attempt to modify the server URL then you 
will be asked to confirm the change. 

Changing the server URL to a non-existent host will render the 
tools unusable until a valid host URL has been entered. Changing 
the server URL before saving any work that has been done during 
the current work session will result in any unsaved data being lost. 

 Important: See notes above regarding changing the URL. 

Auto-login If you are logged onto a CREATE Server then this option will be 
enabled. Once enabled, you can select it to indicate that you 
would like the tools to remember your user name and password 
for the current server and use it to automatically log on to the 
server at any time where you would otherwise be prompted to 
enter user name and password. The password is stored in 
encrypted form in the create preferences file for security reasons. 
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Appearance The default Appearance is that of the host operating system. The 
host operating system appearance normally gives the CREATE 
Tools a look similar to that of other applications on your 
computer. The cross-platform setting provides a consistent user 
interface look and feel regardless of whether you are running the 
software on Windows, Linux, Mac OS X, or some other operating 
system. 

Docked Catalogue and Editors This option (currently only used by the Layout Tool) causes the 
Model Bank Catalogue and Editors side panels to be detached 
from the main application window. When detached, the panels 
appear as floating windows that can be moved freely around your 
computer screen. This is especially useful if you have multiple 
displays attached to your computer as you can then move the 
Catalogue and Editor panels to a different display, giving more 
space to work with the 3D view on your main display.  

 This option takes effect the next time the Layout Tool is started. 

Language The text of the HVRC CREATE tools user interfaces can be 
displayed in English, US English, French or Norwegian. By 
default this option is set to system default, enabling the software 
to select the language automatically depending on your operating 
system language settings. However, you can also select the 
language specifically. For example, this can be useful if you are 
working on an international project where English is the project 
language, but your personal computer is otherwise configured to 
use a non-English language.  

Metric distances If you want distances to be displayed using U.S. measurement 
units then you can turn this option off, otherwise distances are 
displayed in metric units. 

Cache If Model Bank caching is enabled then frequently used models 
load faster as copies of the models are read from the local hard 
drive, rather than transferred over the network, each time the 
model is loaded. The effect of this depends on the speed of the 
network and the size of the models. The greatest benefit of using 
caching is achieved when frequently accessing models over a 
slow connection to a server. Since the model cache is stored on 
the local disk, it is important that there is sufficient disk space (a 
few megabytes is usually sufficient) and that you are not using an 
insecure computer and an insecure user account to access the 
models (from which the cached models could be copied). 

 Pressing “Empty Cache” deletes the data in your local cache, 
freeing up disk space. 

 Caveat: If you are using a computer where your home directory is 
on a server (rather than stored locally on the computer that you are 
using) then turning on the cache may actually slow down the 
loading of Model Bank data, if the network connection to the 
CREATE Server is not significantly slower than the connection to 
your home directory. We do not recommend turning on the 
cache if your home directory is on a network server. 
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6.1.2 3D View Preferences 

 
The 3D View Preferences section of the Preferences Window 

The 3D View Preferences are only applicable to the tools that display 3D graphics, and offer control 
over the way in which the 3D graphics are rendered. These options generally have no effect until the 
application has been restarted as the affect the way in which the 3D view is initialised. 

The 3D View options are described below. 

Enable texture mip-mapping Enable generation of multi-resolution textures when textured 
models are loaded. This option improves the appearance and 
performance of textures, however some older graphics cards may 
not support this feature and the loading of textured models may be 
significantly slower if this option is enabled.  

Enable implicit anti-aliasing Allow the display driver to control full-screen anti-aliasing 
settings. If you have a graphics card with support for anti-aliased 
rendering then this option enables will cause the tool to 
acknowledge your anti-aliasing set-up. This option can greatly 
improve the visual appearance of the 3D view but there may be a 
performance impact, and some older graphics cards may not 
support this feature. 

Enable stereoscopic rendering Enable initialisation of 3D views in stereo mode. This option will 
only have an effect if you have a graphics card that supports 
active stereoscopic rendering. Unless you are actually using 
stereoscopic hardware, you should not enable this option as 
stereoscopic rendering will decrease the overall performance of 
the 3D view as it requires more effort of the graphics card. 
Default off. 

Enable render lock Controls rendering execution. Try changing this if you have driver 
problems. In general, you should leave it off. This option is 
offered only because it can resolve graphics driver problems in 
some special cases. Default off. 

Optimize for space Optimize 3D geometry to use less memory at the expense of 
slower performance. Disable this if you need to squeeze out a 
little more performance. In most cases the difference is 
unperceivable so we recommend leaving it on. Default on. 
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Texture Quality If your layouts contain many high-resolution image surface 
parametric objects then you may reach a point where the 
rendering performance degrades significantly as you run out of 
memory on the GPU. You can improve performance by reducing 
the maximum quality used for texture rendering. Note that the 
images themselves are always stored at high resolution within 
CREATE so this only affects their appearance (both in the 3D 
view and when exporting 2D images). You can safely work with 
this set to Low if you want to maximise performance while 
working on a design, and increase it when you are ready to output 
high quality images. Default is High. 

6.1.3 Proxy Preferences 

 
The Proxy Preferences section of the Preferences Window 

If you are behind a firewall and are using a web proxy server to access the Internet then you will need 
to configure the CREATE tools to use a proxy server if you wish to access a CREATE server that is not 
on your local network (e.g. to access the demonstration server on create.ife.no). 

To enable proxy support, check the Use HTTP Proxy Server option, enter the server address (without 
entering http:// in front of it and without any trailing slashes) in the Proxy Server field and the port 
number in the Port field. If you leave the port field blank then the default port (80) will be used. 

To disable proxy support, uncheck the Use HTTP Proxy Server option. 

If necessary, select Proxy Server Requires Authentication and enter your network (i.e. not CREATE) 
user name and password. 

Note that changing these items while in the middle of doing work with a CREATE tool is not 
recommended. Change these settings immediately after starting up a tool or after saving any 
unfinished work to avoid any risk of data loss. 
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Example of a filled-in Proxy Preferences section of the Preferences Window 

6.1.4 Expert Preferences 

 
The Expert Preferences section of the Preferences Window 

The Expert preferences provide access to additional options, described below. 

Automatic version check Turn off the automatic daily checking for a new release of the 
HVRC CREATE Tools. If you turn this off then you will not be 
informed automatically of new updates, but can still check for 
updates manually via the Help-menu (Help > Check for 
Update). Default on. 

Restrict report image dimensions In versions of CREATE up to 4.0, snapshots of the 3D view 
added to reports in the Verification Tool were exact duplicates 
of the image in the 3D view, with the same resolution and 
aspect. From CREATE 4.0, the snapshots are taken with a 
consistent aspect to always fit neatly into a report page, with 
landscape or portrait format depending on the current 3D view 
aspect. Default on. 

Use larger font for review comments When using a non-Latin character set for entering review 
comments or procedures, some users may find the text easier to 
read if a large font is used than the system default size. Default 
off. 

Watermark exported 2D graphics If this option is enabled then “HVRC CREATE” and the name 
of the licensee is inserted at the top left on exported images. In 
the demo version of CREATE then this cannot be turned off. 
Default off. 
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Detailed technical log in About box Select to enable detailed technical logging of system behaviour 
in the log in the About box. This is useful for troubleshooting if 
you experience technical issues with the software, and you need 
to contact CREATE support for assistance. Enabling this option 
has a small negative effect on the system performance. Default 
off. 

Enable experimental 3D loaders Select to enable 3D loaders, to support importing 3D models in 
glTF, LWO, OBJ, PLY, and SCENE (Ogre3D) formats. These 
are described as experimental as they are not guaranteed to load 
all files in those formats correctly but are useful as they can load 
most files in those formats. Saving your work before attempting 
to import a model for the first time in one of these formats is 
recommend. Default on. 

Clip plane ratio If you experience tearing effects in the 3D view then this may be 
because your graphics processor is unable to draw surfaces that 
are close together with sufficient accuracy. Reducing this 
number may minimise that effect, although at the cost of not 
being able to view near surfaces as closely. Similarly, if you are 
not having any problems with tearing then you might want to try 
increasing this number in order to be able to move even closer to 
surfaces before they disappear from view. A ratio of 1000 is a 
good choice for most modern discrete graphics cards. Default is 
500. 

Ignore project model filter if standalone server If you are using a standalone CREATE Server (as 
opposed to a networked server), on the same machine 
that you are running the CREATE Tools on, then you 
can opt to ignore any project level model filters set for 
the Model Bank. This makes all categories and models 
visible in the Layout Tool regardless of any filters that 
have been specified using the Project Management 
Tool. If you are the only user of the server then this can 
be useful as you will see all new categories added to the 
Model Bank without having to update the project 
context using the Project Management Tool. Default is 
off.  
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